Wie nutze ich CocoaPods richtig mit XCode?

  1. letztes Jahr

    Hallo Zusammen,

    ich bin langsam am verzweifeln was CocoaPods angeht .... (ein hoch auf NuGet und VS)

    Ich habe mir ein neues XCode Projekt angelegt und das CocoaPods XCode Plugin installiert.
    Das neue Projekt ist da und ich habe mir ein PodFile erstellt das wie folgt aussieht:

    platform :ios, '9.2'
    use_frameworks!
    pod 'SwiftHTTP', '~> 1.0'
    pod 'Alamofire', '~> 3.1'

    Danach habe ich die Pods installiert

    /usr/local/bin/pod install
    
    Updating local specs repositories
    
    CocoaPods 1.0.0.beta.2 is available.
    To update use: `gem install cocoapods --pre`
    [!] This is a test version we'd love you to try.
    
    For more information see http://blog.cocoapods.org
    and the CHANGELOG for this version http://git.io/BaH8pQ.
    
    Analyzing dependencies
    Downloading dependencies
    Using Alamofire (3.1.5)
    Using SwiftyJSON (2.3.2)
    Generating Pods project
    Integrating client project
    Pod installation complete! There are 2 dependencies from the Podfile and 2 total pods installed.

    XCode fragt mich nun ob ich den Workspace öffnen möchte was ich mit Ja bestätige. Nun sehe ich auch 2 Projekte einmal mein eigenes und Pods.

    Es ist mir nun aber nicht möglich einen import zu machen in meinem Projekt. Er findet die Referenz nicht.
    Was kann das sein?

    -image-

    Hoffe Ihr könnt mir helfen =)

    Schönes Wochenende

    Gruß Christian

  2. Schon einfach mal ein "clean" gemacht und neu gebaut?

  3. Hallo Jan,

    ja habe ich probiert, aber leider Gottes bringt das rein gar nichts ....

  4. Hier probier es mal damit ?

    vielleicht bringt es dich ja weiter ?

 

oder registriere Dich, um zu antworten!